summaryrefslogtreecommitdiffstats
path: root/02_exercise/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Zabka <zabkaste@hu-berlin.de>2020-06-10 17:11:44 +0200
committerStefan Zabka <zabkaste@hu-berlin.de>2020-06-10 17:11:44 +0200
commit5598f8300b9d3e7b49a4d3e65d1d837616b8beb5 (patch)
tree84fe96600f41f7d9a7b806edf8f27a3fbb82da4e /02_exercise/CMakeLists.txt
parent47aaae2c42d554963fb811b68fdf28c9743598e8 (diff)
parentd80bb89ceaee252cff304c3f7dcb160d3bee8fde (diff)
downloadbetriebssysteme-5598f8300b9d3e7b49a4d3e65d1d837616b8beb5.tar.gz
betriebssysteme-5598f8300b9d3e7b49a4d3e65d1d837616b8beb5.zip
Merge branch 'master' into threadpool
Diffstat (limited to '02_exercise/CMakeLists.txt')
-rw-r--r--02_exercise/CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/02_exercise/CMakeLists.txt b/02_exercise/CMakeLists.txt
index e47f0ee..6bc45c6 100644
--- a/02_exercise/CMakeLists.txt
+++ b/02_exercise/CMakeLists.txt
@@ -7,20 +7,16 @@ set(CMAKE_C_STANDARD 11)
set(CMAKE_C_STANDARD_REQUIRED True)
add_compile_definitions(_GNU_SOURCE)
-
-find_package(Sanitizers)
-
add_executable(prog prog.c)
add_executable(shell shell.c)
target_link_libraries(shell PRIVATE array prompt_utils process builtin)
target_compile_options(shell INTERFACE ${PROJECT_WARNINGS})
-add_sanitizers(shell)
add_library(builtin builtins.c)
target_compile_options(builtin INTERFACE ${PROJECT_WARNINGS})
-add_library(array array.c)
+add_library(array array.c ../03_exercise/srv/shell.h)
add_library(prompt_utils prompt_utils.c)