summaryrefslogtreecommitdiffstats
path: root/04_exercise/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Zabka <zabkaste@hu-berlin.de>2020-06-18 15:04:54 +0200
committerStefan Zabka <zabkaste@hu-berlin.de>2020-06-18 15:05:14 +0200
commit021afcb8e4aa4fbc7905f527089c415108c86c75 (patch)
tree3fd53ab9a1ccdb8b807bb973a4e19da077b871ea /04_exercise/CMakeLists.txt
parent190c347866ebd0c703407285646c6ce3e94f19a4 (diff)
downloadbetriebssysteme-021afcb8e4aa4fbc7905f527089c415108c86c75.tar.gz
betriebssysteme-021afcb8e4aa4fbc7905f527089c415108c86c75.zip
Switched to slotmap
Diffstat (limited to '04_exercise/CMakeLists.txt')
-rw-r--r--04_exercise/CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/04_exercise/CMakeLists.txt b/04_exercise/CMakeLists.txt
index c66bf2c..4e89060 100644
--- a/04_exercise/CMakeLists.txt
+++ b/04_exercise/CMakeLists.txt
@@ -5,7 +5,7 @@ add_executable(quicksort quicksort.c)
target_link_libraries(quicksort PRIVATE threadpool)
add_library(threadpool threadpool.c)
-target_link_libraries(threadpool PRIVATE array Threads::Threads arena_list)
+target_link_libraries(threadpool PRIVATE Threads::Threads slotmap)
target_link_libraries(threadpool INTERFACE warnings)
target_link_libraries(threadpool PUBLIC ppmlib)
@@ -27,4 +27,11 @@ target_include_directories(rwlock PUBLIC rwlock)
target_link_libraries(rwlock INTERFACE warnings)
add_library(ppmlib INTERFACE)
-target_include_directories(ppmlib INTERFACE ppmlib) \ No newline at end of file
+target_include_directories(ppmlib INTERFACE ppmlib)
+
+add_library(slotmap slotmap/slotmap.c)
+target_include_directories(slotmap PUBLIC slotmap)
+target_link_libraries(slotmap INTERFACE warnings)
+
+add_executable(slotmap_test slotmap/slomap_test.c)
+target_link_libraries(slotmap_test PRIVATE slotmap)