summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0f26ea7..55962c2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -43,3 +43,5 @@ set(GCC_WARNINGS
)
set(PROJECT_WARNINGS ${GCC_WARNINGS})
+add_library(warnings INTERFACE)
+target_compile_options(warnings INTERFACE ${PROJECT_WARNINGS})