summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cc780b0..0f26ea7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,8 +11,10 @@ set(CPACK_PROJECT_VERSION ${PROJECT_VERSION})
include(CPack)
add_subdirectory(02_exercise)
+add_subdirectory(03_exercise)
add_subdirectory(04_exercise)
+
set(CLANG_WARNINGS
-Wall
-Wextra # reasonable and standard
@@ -29,6 +31,7 @@ set(CLANG_WARNINGS
# (ie printf)
-Werror
)
+
set(GCC_WARNINGS
${CLANG_WARNINGS}
-Wmisleading-indentation # warn if indentation implies blocks where blocks
@@ -38,4 +41,5 @@ set(GCC_WARNINGS
-Wlogical-op # warn about logical operations being used where bitwise were
# probably wanted
)
+
set(PROJECT_WARNINGS ${GCC_WARNINGS})