summaryrefslogtreecommitdiffstats
path: root/shell/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'shell/CMakeLists.txt')
-rw-r--r--shell/CMakeLists.txt34
1 files changed, 0 insertions, 34 deletions
diff --git a/shell/CMakeLists.txt b/shell/CMakeLists.txt
deleted file mode 100644
index 9cae089..0000000
--- a/shell/CMakeLists.txt
+++ /dev/null
@@ -1,34 +0,0 @@
-cmake_minimum_required(VERSION 3.5)
-
-project(shell C)
-
-set(CMAKE_C_COMPILER gcc)
-set(CMAKE_C_STANDARD 11)
-set(CMAKE_C_STANDARD_REQUIRED True)
-
-find_package(Sanitizers)
-
-add_executable(prog prog.c)
-add_executable(shell shell.c)
-target_link_libraries(shell PRIVATE array prompt_utils process)
-
-add_sanitizers(shell)
-add_compile_definitions(_GNU_SOURCE)
-
-add_library(array array.c)
-
-add_library(prompt_utils prompt_utils.c)
-target_link_libraries(prompt_utils PRIVATE array)
-
-add_executable(prompt_utils_test prompt_utils_test.c)
-target_link_libraries(prompt_utils_test PRIVATE prompt_utils array)
-
-add_library(process process.c)
-target_link_libraries(process PRIVATE array)
-
-add_executable(process_test process_test.c)
-target_link_libraries(process_test PRIVATE process)
-
-target_compile_options(shell INTERFACE ${PROJECT_WARNINGS})
-target_compile_options(prompt_utils INTERFACE ${PROJECT_WARNINGS})
-target_compile_options(process INTERFACE ${PROJECT_WARNINGS})