aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaeseung Ha <ipknhama@gmail.com>2016-09-06 09:40:55 +0900
committerJaeseung Ha <ipknhama@gmail.com>2016-09-06 09:40:55 +0900
commit2cf77c7053db4a14d924573613b6969d8fc51719 (patch)
treef8cb3bab392888dff1c59d0befbc39a8e2e0a6fd /CMakeLists.txt
parente9d41a637303a8b9b1062b10325f75f2a18430f7 (diff)
downloadcrow-2cf77c7053db4a14d924573613b6969d8fc51719.tar.gz
crow-2cf77c7053db4a14d924573613b6969d8fc51719.zip
Skip building SSL example if OpenSSL is not found
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f4db2cf..e2d3bc7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,6 +3,10 @@ project (crow_all)
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/")
find_package(Tcmalloc)
find_package(Threads)
+find_package(OpenSSL)
+if(OPENSSL_FOUND)
+ include_directories(${OPENSSL_INCLUDE_DIR})
+endif()
if (NOT CMAKE_BUILD_TYPE)
message(STATUS "No build type selected, default to Release")