aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoripknHama <ipknhama@gmail.com>2014-08-07 08:31:27 +0900
committeripknHama <ipknhama@gmail.com>2014-08-07 08:31:27 +0900
commitc36aa219e25e26019035fe3465471fd510778422 (patch)
treebea27ec5e1adb3681babd7c818a7de5cb7551e4d /CMakeLists.txt
parent81fcf4af0127d93e817877d0ce1223b606d30fd6 (diff)
downloadcrow-c36aa219e25e26019035fe3465471fd510778422.tar.gz
crow-c36aa219e25e26019035fe3465471fd510778422.zip
now crow becomes completely header only
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b517ae4..338e740 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,11 @@
cmake_minimum_required(VERSION 2.8)
project (crow_all)
+if (NOT CMAKE_BUILD_TYPE)
+ message(STATUS "No build type selected, default to Release")
+ set(CMAKE_BUILD_TYPE "Release")
+endif()
+
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -std=c++1y")
find_package( Boost 1.40 COMPONENTS date_time filesystem system thread REQUIRED )
@@ -14,7 +19,7 @@ ${PROJECT_SOURCE_DIR}/http-parser
include_directories("${PROJECT_INCLUDE_DIR}")
include_directories("${PROJECT_SOURCE_DIR}")
-add_subdirectory(src)
+#add_subdirectory(src)
add_subdirectory(tests)
add_subdirectory(examples)