aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaeseung Ha <ipknhama@gmail.com>2017-09-17 19:17:54 +0900
committerGitHub <noreply@github.com>2017-09-17 19:17:54 +0900
commitd8c4a671760fda8e83279b9383108f0951367fb6 (patch)
tree0ad063878c09eec987d1d8054b66d11fd629ce30 /CMakeLists.txt
parent26c4d5ddef6920043ae40a9d80ca31f3b820bad5 (diff)
parent414809c742521926ca08fbd355b92f3ae877064f (diff)
downloadcrow-d8c4a671760fda8e83279b9383108f0951367fb6.tar.gz
crow-d8c4a671760fda8e83279b9383108f0951367fb6.zip
Merge branch 'master' into master
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e2d3bc7..f7f2d99 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,11 @@
cmake_minimum_required(VERSION 2.8)
project (crow_all)
+
+if(EXISTS "${CMAKE_BINARY_DIR}/conanbuildinfo.cmake")
+include(${CMAKE_BINARY_DIR}/conanbuildinfo.cmake)
+conan_basic_setup()
+endif()
+
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/")
find_package(Tcmalloc)
find_package(Threads)
@@ -24,13 +30,13 @@ endif()
include_directories( ${Boost_INCLUDE_DIR} )
-set(PROJECT_INCLUDE_DIR
+set(PROJECT_INCLUDE_DIR
${PROJECT_SOURCE_DIR}/include
)
include_directories("${PROJECT_INCLUDE_DIR}")
include_directories("${PROJECT_SOURCE_DIR}")
-
+
#add_subdirectory(src)
add_subdirectory(examples)
if (MSVC)