aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoripknHama <ipknhama@gmail.com>2016-08-27 18:03:49 +0900
committeripknHama <ipknhama@gmail.com>2016-08-27 18:03:49 +0900
commite161da45e08a2eaaec747a784020d69f8223418d (patch)
tree0e5c326565e4ddc8fd26d05715666faaf757315f /CMakeLists.txt
parentabc36e1b3ab2edf30ea07ea2a82a395ce312f6f6 (diff)
downloadcrow-e161da45e08a2eaaec747a784020d69f8223418d.tar.gz
crow-e161da45e08a2eaaec747a784020d69f8223418d.zip
Remove warnings: manually applying #101, #104
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0db9139..f4db2cf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,7 +14,7 @@ if (MSVC)
set(Boost_USE_STATIC_LIBS "On")
find_package( Boost 1.52 COMPONENTS system thread regex REQUIRED )
else()
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -std=c++1y")
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -std=c++1y -pedantic -Wextra")
find_package( Boost 1.52 COMPONENTS system thread REQUIRED )
endif()