aboutsummaryrefslogtreecommitdiffstats
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authoripknHama <ipknhama@gmail.com>2014-08-07 01:18:33 +0900
committeripknHama <ipknhama@gmail.com>2014-08-07 01:18:33 +0900
commit031615ac866cc3c8f1900dd4b4aae2106ad31230 (patch)
treeb8b7206ffbd2043368580ec269c97436929fe452 /examples/CMakeLists.txt
parenta0c93f5b84cc11b30bc6320ac26127832ef8bf7a (diff)
downloadcrow-031615ac866cc3c8f1900dd4b4aae2106ad31230.tar.gz
crow-031615ac866cc3c8f1900dd4b4aae2106ad31230.zip
source resturcturing + CMake
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
new file mode 100644
index 0000000..7313adf
--- /dev/null
+++ b/examples/CMakeLists.txt
@@ -0,0 +1,21 @@
+cmake_minimum_required(VERSION 2.8)
+project (crow_examples)
+
+add_executable(example example.cpp)
+target_link_libraries(example crow)
+target_link_libraries(example ${Boost_LIBRARIES} )
+set_target_properties(example PROPERTIES COMPILE_FLAGS "-Wall -std=c++1y")
+
+add_executable(example_chat example_chat.cpp)
+target_link_libraries(example_chat crow)
+target_link_libraries(example_chat ${Boost_LIBRARIES} )
+set_target_properties(example_chat PROPERTIES COMPILE_FLAGS "-Wall -std=c++1y")
+message(${CMAKE_CURRENT_BINARY_DIR})
+message(${PROJECT_SOURCE_DIR})
+add_custom_command(OUTPUT example_chat.html
+ #TARGET example_chat
+ COMMAND ${CMAKE_COMMAND} -E
+ copy ${PROJECT_SOURCE_DIR}/example_chat.html ${CMAKE_CURRENT_BINARY_DIR}/example_chat.html
+ DEPENDS ${PROJECT_SOURCE_DIR}/example_chat.html
+ )
+add_custom_target(example_chat_copy ALL DEPENDS example_chat.html)