aboutsummaryrefslogtreecommitdiffstats
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authoripknHama <ipknhama@gmail.com>2014-08-08 03:53:36 +0900
committeripknHama <ipknhama@gmail.com>2014-08-08 03:53:36 +0900
commit3018ff063acb747065adea877e3e2ac9423f5233 (patch)
tree110f1a6596242b7837c16f88b4838d6fd93dc93c /examples/CMakeLists.txt
parenta0c93f5b84cc11b30bc6320ac26127832ef8bf7a (diff)
parent001c66b378d200bdecc8a4a692c5a73a7d426b8f (diff)
downloadcrow-3018ff063acb747065adea877e3e2ac9423f5233.tar.gz
crow-3018ff063acb747065adea877e3e2ac9423f5233.zip
Merge branch 'directory-restructuring'
Directory structure changed. Crow becomes a complete header-only library with http_parser_merged.h. Provides amalgamated crow_all.h (all feature in one header file).
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
new file mode 100644
index 0000000..031cc04
--- /dev/null
+++ b/examples/CMakeLists.txt
@@ -0,0 +1,22 @@
+cmake_minimum_required(VERSION 2.8)
+project (crow_examples)
+
+add_executable(example example.cpp)
+#target_link_libraries(example crow)
+target_link_libraries(example ${Boost_LIBRARIES} )
+add_custom_command(OUTPUT example_test.py
+ COMMAND ${CMAKE_COMMAND} -E
+ copy ${PROJECT_SOURCE_DIR}/example_test.py ${CMAKE_CURRENT_BINARY_DIR}/example_test.py
+ DEPENDS ${PROJECT_SOURCE_DIR}/example_test.py
+ )
+add_custom_target(example_copy ALL DEPENDS example_test.py)
+
+add_executable(example_chat example_chat.cpp)
+#target_link_libraries(example_chat crow)
+target_link_libraries(example_chat ${Boost_LIBRARIES} )
+add_custom_command(OUTPUT example_chat.html
+ COMMAND ${CMAKE_COMMAND} -E
+ copy ${PROJECT_SOURCE_DIR}/example_chat.html ${CMAKE_CURRENT_BINARY_DIR}/example_chat.html
+ DEPENDS ${PROJECT_SOURCE_DIR}/example_chat.html
+ )
+add_custom_target(example_chat_copy ALL DEPENDS example_chat.html)