aboutsummaryrefslogtreecommitdiffstats
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authoripknHama <ipknhama@gmail.com>2015-02-21 05:46:28 +0900
committeripknHama <ipknhama@gmail.com>2015-02-21 05:46:28 +0900
commit686e5e220b782ef47b5c59271a946bd9603de1d1 (patch)
tree3e2154d22514f78889fb6da0eae991e9526dd7d8 /examples/CMakeLists.txt
parent48811ce4a47200567796730d7467526683f265d7 (diff)
downloadcrow-686e5e220b782ef47b5c59271a946bd9603de1d1.tar.gz
crow-686e5e220b782ef47b5c59271a946bd9603de1d1.zip
Add working example for VS2013 and update CMakeList.txt
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 83b5478..6b42d49 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -1,5 +1,11 @@
cmake_minimum_required(VERSION 2.8)
project (crow_examples)
+
+if (MSVC)
+add_executable(example_vs example_vs.cpp)
+target_link_libraries(example_vs ${Boost_LIBRARIES})
+target_link_libraries(example_vs ${CMAKE_THREAD_LIBS_INIT})
+else ()
add_executable(example example.cpp)
#target_link_libraries(example crow)
@@ -35,3 +41,4 @@ add_custom_target(example_chat_copy ALL DEPENDS example_chat.html)
#SET( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -g -pg" )
#SET( CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -g -pg" )
+endif()