aboutsummaryrefslogtreecommitdiffstats
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorJaeseung Ha <ipknhama@gmail.com>2017-09-17 19:17:54 +0900
committerGitHub <noreply@github.com>2017-09-17 19:17:54 +0900
commitd8c4a671760fda8e83279b9383108f0951367fb6 (patch)
tree0ad063878c09eec987d1d8054b66d11fd629ce30 /examples/CMakeLists.txt
parent26c4d5ddef6920043ae40a9d80ca31f3b820bad5 (diff)
parent414809c742521926ca08fbd355b92f3ae877064f (diff)
downloadcrow-d8c4a671760fda8e83279b9383108f0951367fb6.tar.gz
crow-d8c4a671760fda8e83279b9383108f0951367fb6.zip
Merge branch 'master' into master
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index ef65f02..3c9b0b0 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -19,7 +19,13 @@ endif()
add_executable(example_websocket websocket/example_ws.cpp)
target_link_libraries(example_websocket ${Boost_LIBRARIES})
-target_link_libraries(example_websocket ${CMAKE_THREAD_LIBS_INIT} ssl crypto)
+target_link_libraries(example_websocket ${CMAKE_THREAD_LIBS_INIT} ${OPENSSL_LIBRARIES})
+add_custom_command(OUTPUT ws.html
+ COMMAND ${CMAKE_COMMAND} -E
+ copy ${PROJECT_SOURCE_DIR}/websocket/templates/ws.html ${CMAKE_CURRENT_BINARY_DIR}/templates/ws.html
+ DEPENDS ${PROJECT_SOURCE_DIR}/websocket/templates/ws.html
+ )
+add_custom_target(example_ws_copy ALL DEPENDS ws.html)
add_executable(example example.cpp)
#target_link_libraries(example crow)