aboutsummaryrefslogtreecommitdiffstats
path: root/tests/template/CMakeLists.txt
diff options
context:
space:
mode:
authoripknHama <ipknhama@gmail.com>2014-08-08 03:53:36 +0900
committeripknHama <ipknhama@gmail.com>2014-08-08 03:53:36 +0900
commit3018ff063acb747065adea877e3e2ac9423f5233 (patch)
tree110f1a6596242b7837c16f88b4838d6fd93dc93c /tests/template/CMakeLists.txt
parenta0c93f5b84cc11b30bc6320ac26127832ef8bf7a (diff)
parent001c66b378d200bdecc8a4a692c5a73a7d426b8f (diff)
downloadcrow-3018ff063acb747065adea877e3e2ac9423f5233.tar.gz
crow-3018ff063acb747065adea877e3e2ac9423f5233.zip
Merge branch 'directory-restructuring'
Directory structure changed. Crow becomes a complete header-only library with http_parser_merged.h. Provides amalgamated crow_all.h (all feature in one header file).
Diffstat (limited to 'tests/template/CMakeLists.txt')
-rw-r--r--tests/template/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/tests/template/CMakeLists.txt b/tests/template/CMakeLists.txt
new file mode 100644
index 0000000..86c5d25
--- /dev/null
+++ b/tests/template/CMakeLists.txt
@@ -0,0 +1,29 @@
+cmake_minimum_required(VERSION 2.8)
+project (template_test)
+
+
+set(PROJECT_INCLUDE_DIR
+${PROJECT_SOURCE_DIR}/include
+)
+
+set(TEST_SRCS
+mustachetest.cpp
+)
+
+add_executable(mustachetest ${TEST_SRCS})
+#target_link_libraries(unittest crow)
+#target_link_libraries(unittest ${Boost_LIBRARIES} )
+set_target_properties(mustachetest PROPERTIES COMPILE_FLAGS "-Wall -std=c++1y")
+
+#message(${PROJECT_SOURCE_DIR})
+#message(${CMAKE_CURRENT_BINARY_DIR})
+file(COPY DIRECTORY . DESTINATION ${CMAKE_CURRENT_BINARY_DIR}
+ FILES_MATCHING
+ PATTERN "*.json")
+
+add_custom_command(OUTPUT test.py
+ COMMAND ${CMAKE_COMMAND} -E
+ copy ${PROJECT_SOURCE_DIR}/test.py ${CMAKE_CURRENT_BINARY_DIR}/test.py
+ DEPENDS ${PROJECT_SOURCE_DIR}/test.py
+ )
+add_custom_target(template_test_copy ALL DEPENDS test.py)