aboutsummaryrefslogtreecommitdiffstats
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 1fcec94..83b5478 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -3,7 +3,8 @@ project (crow_examples)
add_executable(example example.cpp)
#target_link_libraries(example crow)
-target_link_libraries(example ${Boost_LIBRARIES} )
+target_link_libraries(example ${Boost_LIBRARIES})
+target_link_libraries(example ${CMAKE_THREAD_LIBS_INIT})
if (Tcmalloc_FOUND)
target_link_libraries(example ${Tcmalloc_LIBRARIES})
@@ -11,7 +12,8 @@ endif(Tcmalloc_FOUND)
add_executable(example_with_all example_with_all.cpp)
#target_link_libraries(example crow)
-target_link_libraries(example_with_all ${Boost_LIBRARIES} )
+target_link_libraries(example_with_all ${Boost_LIBRARIES})
+target_link_libraries(example_with_all ${CMAKE_THREAD_LIBS_INIT})
add_custom_command(OUTPUT example_test.py
COMMAND ${CMAKE_COMMAND} -E
@@ -22,7 +24,8 @@ add_custom_target(example_copy ALL DEPENDS example_test.py)
add_executable(example_chat example_chat.cpp)
#target_link_libraries(example_chat crow)
-target_link_libraries(example_chat ${Boost_LIBRARIES} )
+target_link_libraries(example_chat ${Boost_LIBRARIES})
+target_link_libraries(example_chat ${CMAKE_THREAD_LIBS_INIT})
add_custom_command(OUTPUT example_chat.html
COMMAND ${CMAKE_COMMAND} -E
copy ${PROJECT_SOURCE_DIR}/example_chat.html ${CMAKE_CURRENT_BINARY_DIR}/example_chat.html