summaryrefslogtreecommitdiffstats
path: root/02_exercise/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Zabka <zabkaste@hu-berlin.de>2020-05-24 12:09:46 +0200
committerStefan Zabka <zabkaste@hu-berlin.de>2020-05-24 12:09:46 +0200
commit65966ded0cc15c5966c6568cf0ff2f2bbe1fc29a (patch)
tree60af69be16926ef0f24ad2a954d9205ce9277450 /02_exercise/CMakeLists.txt
parent3b7e61eab8ce5d230bc1b172942c1ab9459ed161 (diff)
downloadbetriebssysteme-65966ded0cc15c5966c6568cf0ff2f2bbe1fc29a.tar.gz
betriebssysteme-65966ded0cc15c5966c6568cf0ff2f2bbe1fc29a.zip
Big remodelling
Diffstat (limited to '02_exercise/CMakeLists.txt')
-rw-r--r--02_exercise/CMakeLists.txt57
1 files changed, 0 insertions, 57 deletions
diff --git a/02_exercise/CMakeLists.txt b/02_exercise/CMakeLists.txt
deleted file mode 100644
index ca67d1a..0000000
--- a/02_exercise/CMakeLists.txt
+++ /dev/null
@@ -1,57 +0,0 @@
-cmake_minimum_required(VERSION 3.5)
-
-project(shell C)
-
-set(CMAKE_C_COMPILER gcc)
-set(CMAKE_C_STANDARD 11)
-set(CMAKE_C_STANDARD_REQUIRED True)
-
-add_executable(prog prog.c)
-add_executable(shell shell.c)
-target_link_libraries(shell PRIVATE array prompt_utils process)
-add_compile_definitions(_GNU_SOURCE)
-
-add_library(array array.c)
-
-add_library(prompt_utils prompt_utils.c)
-target_link_libraries(prompt_utils PRIVATE array)
-
-add_executable(prompt_utils_test prompt_utils_test.c)
-target_link_libraries(prompt_utils_test PRIVATE prompt_utils array)
-
-add_library(process process.c)
-target_link_libraries(process PRIVATE array)
-
-add_executable(process_test process_test.c)
-target_link_libraries(process_test PRIVATE process)
-
-
-
-set(CLANG_WARNINGS
- -Wall
- -Wextra # reasonable and standard
- -Wshadow # warn the user if a variable declaration shadows one from a
- # parent context
- -Wcast-align # warn for potential performance problem casts
- -Wunused # warn on anything being unused
- -Wpedantic # warn if non-standard C++ is used
- -Wconversion # warn on type conversions that may lose data
- -Wsign-conversion # warn on sign conversions
- -Wnull-dereference # warn if a null dereference is detected
- -Wdouble-promotion # warn if float is implicit promoted to double
- -Wformat=2 # warn on security issues around functions that format output
- # (ie printf)
- -Werror
- )
-set(GCC_WARNINGS
- ${CLANG_WARNINGS}
- -Wmisleading-indentation # warn if indentation implies blocks where blocks
- # do not exist
- -Wduplicated-cond # warn if if / else chain has duplicated conditions
- -Wduplicated-branches # warn if if / else branches have duplicated code
- -Wlogical-op # warn about logical operations being used where bitwise were
- # probably wanted
- )
-set(PROJECT_WARNINGS ${GCC_WARNINGS})
-target_compile_options(shell INTERFACE ${PROJECT_WARNINGS})
-target_compile_options(prompt_utils INTERFACE ${PROJECT_WARNINGS}) \ No newline at end of file