summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Zabka <zabkaste@hu-berlin.de>2020-06-10 19:59:12 +0200
committerStefan Zabka <zabkaste@hu-berlin.de>2020-06-10 19:59:12 +0200
commit1bec4c4e1e16aa12965d124f83590ba007b88719 (patch)
tree070dd35bf017e6e09f6c13a144d9090856d30fdf /CMakeLists.txt
parented398e3a61d696c7f07506f80563f5697e230b93 (diff)
downloadbetriebssysteme-1bec4c4e1e16aa12965d124f83590ba007b88719.tar.gz
betriebssysteme-1bec4c4e1e16aa12965d124f83590ba007b88719.zip
Finally getting all the warnings
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0f26ea7..55962c2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -43,3 +43,5 @@ set(GCC_WARNINGS
)
set(PROJECT_WARNINGS ${GCC_WARNINGS})
+add_library(warnings INTERFACE)
+target_compile_options(warnings INTERFACE ${PROJECT_WARNINGS})