summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Zabka <zabkaste@hu-berlin.de>2020-06-10 17:11:44 +0200
committerStefan Zabka <zabkaste@hu-berlin.de>2020-06-10 17:11:44 +0200
commit5598f8300b9d3e7b49a4d3e65d1d837616b8beb5 (patch)
tree84fe96600f41f7d9a7b806edf8f27a3fbb82da4e /CMakeLists.txt
parent47aaae2c42d554963fb811b68fdf28c9743598e8 (diff)
parentd80bb89ceaee252cff304c3f7dcb160d3bee8fde (diff)
downloadbetriebssysteme-5598f8300b9d3e7b49a4d3e65d1d837616b8beb5.tar.gz
betriebssysteme-5598f8300b9d3e7b49a4d3e65d1d837616b8beb5.zip
Merge branch 'master' into threadpool
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cc780b0..0f26ea7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,8 +11,10 @@ set(CPACK_PROJECT_VERSION ${PROJECT_VERSION})
include(CPack)
add_subdirectory(02_exercise)
+add_subdirectory(03_exercise)
add_subdirectory(04_exercise)
+
set(CLANG_WARNINGS
-Wall
-Wextra # reasonable and standard
@@ -29,6 +31,7 @@ set(CLANG_WARNINGS
# (ie printf)
-Werror
)
+
set(GCC_WARNINGS
${CLANG_WARNINGS}
-Wmisleading-indentation # warn if indentation implies blocks where blocks
@@ -38,4 +41,5 @@ set(GCC_WARNINGS
-Wlogical-op # warn about logical operations being used where bitwise were
# probably wanted
)
+
set(PROJECT_WARNINGS ${GCC_WARNINGS})