summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNiklas Halle <niklas@niklashalle.net>2020-06-06 14:06:00 +0200
committerNiklas Halle <niklas@niklashalle.net>2020-06-06 14:06:00 +0200
commite1520589de17d08c4bde37f1198f18d012a1f377 (patch)
treeb4a0f93466c9c53688bad02c69d39d409d23ce5b /CMakeLists.txt
parent74abc79434fe895d0ca863e4d1d6c5c16b54f296 (diff)
downloadbetriebssysteme-e1520589de17d08c4bde37f1198f18d012a1f377.tar.gz
betriebssysteme-e1520589de17d08c4bde37f1198f18d012a1f377.zip
basic shell works - sometimes goes out of sync (running current command only after issueing the next)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 41de2c8..5d0441e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,6 +28,7 @@ set(CLANG_WARNINGS
# (ie printf)
-Werror
)
+
set(GCC_WARNINGS
${CLANG_WARNINGS}
-Wmisleading-indentation # warn if indentation implies blocks where blocks
@@ -37,4 +38,5 @@ set(GCC_WARNINGS
-Wlogical-op # warn about logical operations being used where bitwise were
# probably wanted
)
+
set(PROJECT_WARNINGS ${GCC_WARNINGS})