summaryrefslogtreecommitdiffstats
path: root/02_exercise/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '02_exercise/CMakeLists.txt')
-rw-r--r--02_exercise/CMakeLists.txt20
1 files changed, 14 insertions, 6 deletions
diff --git a/02_exercise/CMakeLists.txt b/02_exercise/CMakeLists.txt
index 9cae089..e47f0ee 100644
--- a/02_exercise/CMakeLists.txt
+++ b/02_exercise/CMakeLists.txt
@@ -5,30 +5,38 @@ project(shell C)
set(CMAKE_C_COMPILER gcc)
set(CMAKE_C_STANDARD 11)
set(CMAKE_C_STANDARD_REQUIRED True)
+add_compile_definitions(_GNU_SOURCE)
+
find_package(Sanitizers)
add_executable(prog prog.c)
-add_executable(shell shell.c)
-target_link_libraries(shell PRIVATE array prompt_utils process)
+add_executable(shell shell.c)
+target_link_libraries(shell PRIVATE array prompt_utils process builtin)
+target_compile_options(shell INTERFACE ${PROJECT_WARNINGS})
add_sanitizers(shell)
-add_compile_definitions(_GNU_SOURCE)
+
+add_library(builtin builtins.c)
+target_compile_options(builtin INTERFACE ${PROJECT_WARNINGS})
add_library(array array.c)
+
add_library(prompt_utils prompt_utils.c)
target_link_libraries(prompt_utils PRIVATE array)
+target_compile_options(prompt_utils INTERFACE ${PROJECT_WARNINGS})
add_executable(prompt_utils_test prompt_utils_test.c)
target_link_libraries(prompt_utils_test PRIVATE prompt_utils array)
+
add_library(process process.c)
target_link_libraries(process PRIVATE array)
+target_compile_options(process INTERFACE ${PROJECT_WARNINGS})
add_executable(process_test process_test.c)
target_link_libraries(process_test PRIVATE process)
-target_compile_options(shell INTERFACE ${PROJECT_WARNINGS})
-target_compile_options(prompt_utils INTERFACE ${PROJECT_WARNINGS})
-target_compile_options(process INTERFACE ${PROJECT_WARNINGS})
+
+