aboutsummaryrefslogtreecommitdiffstats
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authoripknHama <ipknhama@gmail.com>2014-08-07 04:46:28 +0900
committeripknHama <ipknhama@gmail.com>2014-08-07 04:46:28 +0900
commite70380e003ae28822a6b903193c9a699cc02c405 (patch)
tree529a655ab16dc121024723d820edcfd192d381b5 /examples/CMakeLists.txt
parent031615ac866cc3c8f1900dd4b4aae2106ad31230 (diff)
downloadcrow-e70380e003ae28822a6b903193c9a699cc02c405.tar.gz
crow-e70380e003ae28822a6b903193c9a699cc02c405.zip
cmake update, added template test
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt11
1 files changed, 6 insertions, 5 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 7313adf..24150f0 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -4,16 +4,17 @@ project (crow_examples)
add_executable(example example.cpp)
target_link_libraries(example crow)
target_link_libraries(example ${Boost_LIBRARIES} )
-set_target_properties(example PROPERTIES COMPILE_FLAGS "-Wall -std=c++1y")
+add_custom_command(OUTPUT example_test.py
+ COMMAND ${CMAKE_COMMAND} -E
+ copy ${PROJECT_SOURCE_DIR}/example_test.py ${CMAKE_CURRENT_BINARY_DIR}/example_test.py
+ DEPENDS ${PROJECT_SOURCE_DIR}/example_test.py
+ )
+add_custom_target(example_copy ALL DEPENDS example_test.py)
add_executable(example_chat example_chat.cpp)
target_link_libraries(example_chat crow)
target_link_libraries(example_chat ${Boost_LIBRARIES} )
-set_target_properties(example_chat PROPERTIES COMPILE_FLAGS "-Wall -std=c++1y")
-message(${CMAKE_CURRENT_BINARY_DIR})
-message(${PROJECT_SOURCE_DIR})
add_custom_command(OUTPUT example_chat.html
- #TARGET example_chat
COMMAND ${CMAKE_COMMAND} -E
copy ${PROJECT_SOURCE_DIR}/example_chat.html ${CMAKE_CURRENT_BINARY_DIR}/example_chat.html
DEPENDS ${PROJECT_SOURCE_DIR}/example_chat.html