aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNiklas Halle <niklas@niklashalle.net>2020-08-23 17:40:25 +0200
committerNiklas Halle <niklas@niklashalle.net>2020-08-23 17:40:25 +0200
commitb5b8de1b3005ff6c6e3659d32b851a85f6671d88 (patch)
tree6f2a54196a3b2c2d29dfaeaf7e6a8b9e43f33ba6 /CMakeLists.txt
parentb3e3f3f50e49c6d21032e44565a93ed96d99801b (diff)
downloadn_core-b5b8de1b3005ff6c6e3659d32b851a85f6671d88.tar.gz
n_core-b5b8de1b3005ff6c6e3659d32b851a85f6671d88.zip
added some helper functions and a nice enum for annotation handling, as well as an more complex reply example (multi annotaion, link annotation
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 53d1f7e..aeecbf3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,9 +14,12 @@ ENDIF ()
add_executable(${PROJECT_NAME}
# Headers
+ include/AnnotationTypes.hpp
+ include/Enum2String.hpp
# Sources
src/main.cpp
+ src/Enum2String.cpp
)
target_include_directories(${PROJECT_NAME}